Install Hiptest publisher on Amazon Linux Instance

Hello, I tried to install hiptest publisher on Amazon linux instance but I obtained this error:

gem install hiptest-publisher
 
ERROR:  Error installing hiptest-publisher:
	nokogiri requires Ruby version >= 2.1.0.

Could you help me, please?

Hello Michele,

I think you should try to upgrade ruby to a version >= 2.2.4. To do that, the easier steps are to install RVM. Take a look to https://tecadmin.net/install-ruby-2-2-on-centos-rhel/

Spoiler:

Required packages

sudo yum install gcc-c++ patch readline readline-devel zlib zlib-devel
sudo yum install libyaml-devel libffi-devel openssl-devel make
sudo yum install bzip2 autoconf automake libtool bison iconv-devel sqlite-devel

RVM

curl -sSL https://rvm.io/mpapis.asc | gpg --import -
curl -L get.rvm.io | bash -s stable
source /home/ec2-user/.rvm/scripts/rvm
rvm reload
rvm requirements run

Install ruby 2.2

rvm install 2.2.4
rvm use 2.2.4 --default

Check ruby version

ruby --version

And after, you can install Hiptest publisher gem without troubles

gem install hiptest-publisher

It should work now.
Happy testing!

1 Like

Hello Severine, with RVM installation, it works!
Thank you very much.

1 Like